সর্বশেষ সম্পাদনা করেছেন linx_freak (১০-০৯-২০১২ ১৩:২৫)

টপিকঃ Mikrotik রিডানডেন্সি

Mikrotik রিডানডেন্সি

ধরুন আপনার নেটওয়ার্কে দুটি কিংবা এর অধিক রাউটার আছে। প্রত্যেকটি আলাদা আলাদা আইএসপির সাথে যুক্ত। এখন যদি একটি কানেকশান ডাউন হয় তবে আপনাকে নেটওয়ার্ক এর প্রত্যেকটি পিসির গেটওয়ে বদলাতে হয় যেন আরেকটি আইএসপির কানেকশান ব্যাবহার করা যায়। ছোটখাট নেটওয়ার্কে এটা সম্ভব হলেই একটু বড় নেটওয়ার্কে তা বেশ সময় সাপেক্ষ , বিশেষ করে যদি ডাটা সেন্টার হয়।এতে আপটাইম ৯৯% রাখা সম্ভব না।

কিন্তু এমন যদি করা যায় একটি আপলিঙ্ক ডাউন হলে ট্রাফিক স্বয়ংক্রিয়ভাবে আরেকটি রাউটার দিয়ে চলে যাবে, আলাদা করে নেটওয়ার্কের সব হোসট এর গেটওয়ে বদলে দেবার দরকার পরবে না তাহলে খুব ভাল হয়। Mikrotik রাউটারে VRRP (Virtual Router Redundancy Protocol) সহজেই এটা করা সম্ভব। যারা Cisco রাউটার এ কাজ করেছেন তারা BGP রাউটিঙের সাথে পরিচিত। Mikrotik এ VRRP BGP এর মতোই কাজ করে। চলুন এবার mikrotik এ VRRP কনফিগার করি। প্রথম উদাহরণে আমরা একটি সাধারণ রিডানডেন্সি তৈরি করব। এতে Mikrotik1 যখন ডাউন হবে তখন User PC থেকে আসা ট্রাফিক স্বয়ংক্রিয়ভাবে Mikrotik2 দিয়ে চলে যাবে। ডাউন টাইম থাকবেনা বল্যেই চলে।

http://projanmo.5gbfree.com/mikrotik/Mikrotik_Redundancy.png


Mikrotik1 কনফিগারেশান

/ip address add address=172.16.16.1/24 interface=ether1
/interface vrrp add interface=ether1 vrid=55 priority=254
/ip address add address=172.16.16.150/32 interface=vrrp1

এতে দেখুন priority=254 সেট করা হয়েছে যেন Mikrotik1 কে মাস্টার রাউটার হিসেবে ব্যাবহার করা হয়।

Mikrotik2 কনফিগারেশান

/ip address add address=172.16.16.2/24 interface=ether1
/interface vrrp add interface=ether1 vrid=55
/ip address add address=172.16.16.150/32 interface=vrrp1

আপাতত কাজ শেষ। এবার চেক করার পালা। Mikrotik1 এর টার্মিনাল এ লিখুন

/interface vrrp print
 0   RM name="vrrp1" mtu=1500 mac-address=00:0E:40:0E:01:47 arp=enabled interface=ether1 vrid=55 
        priority=254 interval=1 preemption-mode=yes authentication=none password="" on-backup="" 
        on-master="" 

Mikrotik2 এর টার্মিনাল এ লিখুন

/interface vrrp print
 0    B name="vrrp1" mtu=1500 mac-address= 00:0E:40:0E:01:47 arp=enabled interface=ether1 vrid=55 
        priority=100 interval=1 preemption-mode=yes authentication=none password=""
        on-backup="" on-master="

খেয়াল করে দেখুন দুটো রাউটার এর vrrp MAC-ADDRESS একই। অর্থাৎ VRRP ঠিকঠাক কনফিগার হয়েছে। এবার User PC থেকে ব্রাউজ করুন। যদি  ব্রাউজ করা যায় তবে Mikrotik1 ওয়ান ক্যাবল আনপ্লাগ করে ব্রাউজ করুন। সবঠিক থাকলে পিসির গেটওয়ে না বদলেই ব্রাউজ করতে পারবেন।

এভাবে করা VRRP তে একটি কানেকশান Mikrotik2 প্রায় সময়ে অলস পড়ে থাকবে। এটা ব্যান্ডউইথ এর অপচয় বলা যায়। চলুন এর সাথে ছোট কিছু কনফিগারেশান যোগ করে Mikrotik1 এর লোড Mikrotik2 এর সাথে শেয়ার করে দেই। এতে রিডানডেন্সি বলবৎ থাকবে।

http://projanmo.5gbfree.com/mikrotik/Mikrotik_Redundancy2.png

Mikrotik1 কনফিগারেশান

/ip address add address=172.16.16.1/24 interface=ether1
/interface vrrp add interface=ether1 vrid=55 priority=254
/interface vrrp add interface=ether1 vrid=57 
/ip address add address=172.16.16.150/32 interface=vrrp1
/ip address add address=172.16.16.160/32 interface=vrrp2

Mikrotik2 কনফিগারেশান

/ip address add address=172.16.16.2/24 interface=ether1
/interface vrrp add interface=ether1 vrid=55
/interface vrrp add interface=ether1 vrid=57 priority=254
/ip address add address=172.16.16.150/32 interface=vrrp1
/ip address add address=172.16.16.160/32 interface=vrrp2

এতে mikrotik1 ও mikrotik2 একে ওপরের ব্যাকআপ সার্ভার হিসেবে কাজ করবে। এবার ইউজার১ এবং ইউজার২ কে গেটওয়ে 172.16.16.150 ও ইউজার৩ এবং ইউজার৪ কে গেটওয়ে 172.16.16.160 তে কনফিগার করুন। ব্যাস এবার আপনাকে আর চিন্তা করতে হবেনা। যেকোনো একটি রাউটার ইন্টারনেট এ কানেক্টেড থাকলেই আপনার নেটওয়ার্ক ডাউন হবার সম্ভাবনা নাই।

জ্ঞান হোক উম্মুক্ত

Re: Mikrotik রিডানডেন্সি

PPPOE কানেকশনে মেনুয়ালি IP বসানোর কোন রাস্তা আছে?  neutral

লেখাটি CC by-nd 3.0 এর অধীনে প্রকাশিত

Re: Mikrotik রিডানডেন্সি

ভাই ধন্যপাতা দিলাম আপনাকে।  smile

সর্বশেষ সম্পাদনা করেছেন linx_freak (১০-০৯-২০১২ ১৩:৩০)

Re: Mikrotik রিডানডেন্সি

shitol69 লিখেছেন:

PPPOE কানেকশনে মেনুয়ালি IP বসানোর কোন রাস্তা আছে?  neutral

হ্যাঁ... আপনার ইথারনেট ইন্টারফেস এ ম্যানুয়ালি আইপি বসিয়ে দিন। কিন্তু আপনার ISP যদি আপনার MAC অথবা PPPoE ইউজার নেম এর সাথে আইপি ফিক্সড করে রাখে তাহলে হয়ত কাজ নাও করতে পারে।

sohel2020 লিখেছেন:

ভাই ধন্যপাতা দিলাম আপনাকে।:)

আপনাকেও ধন্যবাদ  smile

জ্ঞান হোক উম্মুক্ত