সর্বশেষ সম্পাদনা করেছেন linx_freak (১২-০৮-২০১২ ২১:০৪)

টপিকঃ Mikrotik লোড ব্যাল্যান্স

Mikrotik লোড ব্যাল্যান্স

আপনার যদি দুটি wan কানেকশান থাকে তাহলে আপনি দুটো কানেকশান কেই উত্তমরূপে (পয়সা উসুল টাইপ) ব্যাবহার এর উদ্দেশ্যে সমান ভাবে অথবা চাহিদা মত ব্যাল্যান্স করতে চাইতে পারেন। Cisco তে RIP, RIPv2, IGRP, EIGRP, OSPF ইত্যাদি প্রটকল এর মাধ্যমে করা হয় । Mikrotik এও বেশ কয়েকভাবেই করা যায়।

এই উদাহরণে আমরা src-address কে ক্লাসিফায়ার হিসেবে pcc ( per-connection-classifier ) এর সাথে ব্যাবহার করব। কারণ এই পদ্ধতি  ব্যাবহারে কিছু সমস্যা যেমন, ssl,http link broken, streaming files, torrent ইত্যাদি সংযোগ বিচ্ছিন্ন হবার মত ঘটনা কমে যাবে । একতা বেপার খেয়াল করে দেখবেন, বিভিন্ন ব্যাংক, আর্থিক প্রতিষ্ঠান, hosting কোম্পানি, বিভিন্ন ফোরাম ইত্যাদি সাইট এর একটা HTTP রিকোয়েস্ট এর কানেকশান একাধিক হয়ে থাকে। এখন এই HTTP রিকোয়েস্ট  এর  কিছু কানেকশান আপনার wlan1 কিছু কানেকশান wlan2 দিয়ে রাউট হলে আপনার গ্রাহকেরা ওয়েবপেজ দেখতে পাবেন না। এইধরনের সমস্যাগুলো পাশ কাটাতে আমি PCC পদ্ধতির জন্য scr-address কে বেছে নিয়েছি।

শুরু করার আগে একটা কথা বলে রাখি। আমিও এই লাইনে গুরুদের টিউটোরিয়াল দেখে দেখে শিখেছি। তবে প্রজান্মতে দেয়া সব টিউটোরিয়ালই ব্যক্তিগতভাবে পরিক্ষিত , ব্যবহৃত এবং বাস্তব জীবনে কর্মক্ষম । বাহ আমিতো অনেক কঠিন বাংলা লিখে ফেললাম।  big_smile

আরেকটা কথা, সারিম ভাইকেও অনেক অনেক ধন্যবাদ। উনার দেয়া ওরস্যালাইন এ আমার অভ্র পুনরায় কাজ শুরু করেছে। নাহলে লেখাটা শেষ করতে পারতাম নাহ।  thumbs_up

এবার কাজের কথায় আসি। আগের টিউটোরিয়াল এ আমরা দুটি ইন্টারফেস  Lan ও wanব্যাবহার করেছিলাম। এই টিউটোরিয়াল এ তিনটি ব্যাবহার করবো। ১. Lan ২. Wan1 ৩. Wan2

http://projanmo.5gbfree.com/mikrotik/load.jpg

লিনাক্স থেকে কাজটা করেছি। তাই CLI তে কাজগুলো শেষ কওরা হয়েছে। আপনারাও CLI প্রম্পট ব্যাবহার করুন।এতে পরবর্তীতে যেকোনো mode এ কাজ করতে পারবেন।

এবার প্রথমে আপনার Mikrotik এ লগইন করুন।
ইন্টারফেস গুলোতে IP বসাতে নিচের মত কমান্ড টাইপ করুন।


/ip address
add address=10.0.0.1/8 network=10.0.0.0 broadcast=10.255.255.255 interface=lan
add address=192.168.2.1/24 network=192.168.1.0 broadcast=192.168.1.255 interface=wan1
add address=192.168.3.1/24 network=192.168.3.0 broadcast=192.168.3.255 interface=wan2

DNSসার্ভার সেট করুন। 

/ip dns set allow-remote-requests=yes cache-max-ttl=1w cache-size=5000KiB max-udp-packet-size=512 servers=4.2.2.1,8.8.8.8

এই টিউটোরিয়াল এ ব্যাবহার করা দুটি DNS সার্ভারই পাবলিক DNS। চেষ্টা করবেন অন্তত প্রাইমারি হিসেবে (উপরে 4.2.2.1 এর জায়গায়) আপনার ISP দ্বারা সরবরাহকৃত DNS ব্যাবহার করার। এতে আপনার নেটওয়ার্ক ব্যবহারকারিদের ব্রাউজিং পারফরমেন্স বৃদ্ধি পাবে।

এবার packet mark করার জন্য নিচের কমান্ডগুলো প্রয়োগ করুন।

/ip firewall mangle
add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=WAN1_conn
add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=WAN2_conn


add chain=output connection-mark=WAN1_conn action=mark-routing new-routing-mark=to_WAN1
add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2

প্রিরাউটিং যোগ করুন

add chain=prerouting dst-address=192.168.2.0/24 action=accept in-interface=lan
add chain=prerouting dst-address=192.168.3.0/24 action=accept in-interface=lan


add chain=prerouting dst-address-type=!lan in-interface=lan per-connection-classifier=both-addresses-and-ports:2/0 action=mark-connection new-connection-mark=wan1_conn passthrough=yes
add chain=prerouting dst-address-type=!lan in-interface=lan per-connection-classifier=both-addresses-and-ports:2/1 action=mark-connection new-connection-mark=wan2_conn passthrough=yes
<**এই লাইনটি আপাতত এড়িয়ে যান**>


add chain=prerouting connection-mark=wan1_conn in-interface=lan action=mark-routing new-routing-mark=to_wan1
add chain=prerouting connection-mark=wan2_conn in-interface=lan action=mark-routing new-routing-mark=to_wan2

Mark করা src-address এবং PCC প্যাকেটগুলো wan গেটওয়ে প্রেরণ

/ip route
add dst-address=0.0.0.0/0 gateway=192.168.2.5 routing-mark=to_wan1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.3.7 routing-mark=to_wan2 check-gateway=ping

add dst-address=0.0.0.0/0 gateway=192.168.2.5 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.3.7 distance=2 check-gateway=ping

নোট : আপনি আপনার ISP প্রদত্ত gateway ব্যাবহার করবেন।
সবশেষে নিচের কমান্ড দ্বারা masquerade চালু কওরে দিন।

/ip firewall nat
add chain=srcnat out-interface=wan1 action=masquerade
add chain=srcnat out-interface=wan2 action=masquerade
সব সম্পন্ন হয়েছে। এবার আপনি আপনার ব্যবহারকারীদের দ্বারা লোড লিংকটি পরীক্ষা করুন।

কিন্তু ধরুন আপনার দুটি wan লিঙ্কে ব্যান্ডউইথ এর পরিমাণ ভিন্ন, তখন? অর্থাৎ আপনার wan1 এ ব্যান্ডউইথ 1Mbps এবং wan2 তে 2Mbps। স্বভাবতই আপনি চাইবেন wan2 তে ট্রাফিক এর পরিমাণ বাড়িয়ে দিতে। এর জন্য  প্রিরাউটিং এর ২য় প্যারার শেষ এ এই লাইনটি যোগ করেদিন।  (<**এই অংশটি আপাতত এড়িয়ে যান**> লাইনটি মুছে নিচের অংশটি বসিয়ে দিন)

add chain=prerouting dst-address-type=!lan in-interface=lan per-connection-classifier=both-addresses-and-ports:2/2 action=mark-connection new-connection-mark=wan2_conn passthrough=yes
এতে wan2 তে ট্রাফিক এর পরিমাণ বেড়ে যাবে।

জ্ঞান হোক উম্মুক্ত

Re: Mikrotik লোড ব্যাল্যান্স

ওয়ে ওয়ে, গ্রেট টিউটো।  thumbs_up

Re: Mikrotik লোড ব্যাল্যান্স

চমৎকার।

আশিকুর_নূর'এর ওয়েবসাইট

লেখাটি CC by-nc-nd 3. এর অধীনে প্রকাশিত

Re: Mikrotik লোড ব্যাল্যান্স

বাবর লিখেছেন:

ওয়ে ওয়ে, গ্রেট টিউটো।

আশিকুর_নূর লিখেছেন:

চমৎকার।

ক্ষুদ্র জ্ঞান এর ক্ষুদ্র প্রচেষ্টা। আপনাদের দুজনকে ধন্যবাদ।  smile

জ্ঞান হোক উম্মুক্ত

Re: Mikrotik লোড ব্যাল্যান্স

হাই লেভেলের টেকি টিউটোরিয়ালগুলোতে কমেন্ট কম হয়, তাই কমেন্টের অপেক্ষায় না থেকে মিক্রোটিক নিয়ে লেখা চালিয়ে যান mail বেশ কিছু লেখা হলে একটা সূচীপত্র করে তারপর সেটাকে স্টিকি করার অনুরোধ করা যাবে মডুদের কাছে।

Re: Mikrotik লোড ব্যাল্যান্স

দক্ষিণের-মাহবুব লিখেছেন:

হাই লেভেলের টেকি টিউটোরিয়ালগুলোতে কমেন্ট কম হয়, তাই কমেন্টের অপেক্ষায় না থেকে মিক্রোটিক নিয়ে লেখা চালিয়ে যান mail বেশ কিছু লেখা হলে একটা সূচীপত্র করে তারপর সেটাকে স্টিকি করার অনুরোধ করা যাবে মডুদের কাছে।

100% সহমত