সর্বশেষ সম্পাদনা করেছেন শামীম (১৩-০৬-২০১৩ ১১:৪২)

টপিকঃ লিনাক্স মিন্ট ১৩ মায়াতে ব্রোকেন প্যাকেজ / ডিপেন্ডেন্সি সমস্যা - solved

আমার ল্যাপটপে ৩টা ব্রোকেন প্যাকেজ আছে। কিছুতেই ফিক্স হচ্ছে না। যার ফলে বেশ কিছু কাজ করতে পারছি না।

প্রথমে কম্পু সম্পর্কে:
================================================
HP-Pavilion-dv4-Notebook-PC

অপারেটিং সিস্টেম: লিনাক্স মিন্ট
Release 13 (maya) 64-bit
Kernel Linux 3.2.0-23-generic
GNOME 3.4.2

হার্ডওয়্যার:
মেমরি:  3.8 GiB
প্রসেসর: Intel® Core™2 Duo CPU T5800 @ 2.00GHz × 2
================================================

ফিক্স ব্রোকেন প্যাকেজ দিলে এই তিনটা ঠিক করবে বলে মেসেজ দেয়:

libnss3 (version 3.13.1.with.ckbi.1.88-1ubuntu6.1) will be upgraded to version 3.14.3-0ubuntu0.12.04.1
libnss3-1d (version 3.14.1-0ckbi1.93ubuntu.0.12.04.1) will be upgraded to version 3.14.3-0ubuntu0.12.04.1
libnss3:i386 (version 3.14.1-0ckbi1.93ubuntu.0.12.04.1) will be upgraded to version 3.14.3-0ubuntu0.12.04.1

কিন্তু ফিক্স করতে বললে, ডাউনলোডের পর ইনস্টল করতে গিয়ে নিচের এরর মেসেজ দিয়ে বের হয়ে আসে।

E: libnss3: libnss3:amd64 3.13.1.with.ckbi.1.88-1ubuntu6.1 cannot be configured because libnss3
E: libnss3-1d: dependency problems - leaving unconfigured
E: libreoffice-core: dependency problems - leaving unconfigured
E: libnm-util2: dependency problems - leaving unconfigured
E: libnm-glib4: dependency problems - leaving unconfigured
E: network-manager: dependency problems - leaving unconfigured
E: openjdk-6-jre-headless: dependency problems - leaving unconfigured
E: gir1.2-networkmanager-1.0: dependency problems - leaving unconfigured
E: libnm-glib-vpn1: dependency problems - leaving unconfigured
E: libnm-gtk0: dependency problems - leaving unconfigured
E: libpurple0: dependency problems - leaving unconfigured
E: libreoffice-base-core: dependency problems - leaving unconfigured
E: openjdk-6-jre: dependency problems - leaving unconfigured
E: libreoffice-base: dependency problems - leaving unconfigured
E: libreoffice-calc: dependency problems - leaving unconfigured
E: libreoffice-draw: dependency problems - leaving unconfigured
E: python-uno: dependency problems - leaving unconfigured
E: libreoffice-emailmerge: dependency problems - leaving unconfigured
E: libreoffice-gtk: dependency problems - leaving unconfigured
E: libreoffice-gnome: dependency problems - leaving unconfigured
E: libreoffice-writer: dependency problems - leaving unconfigured
E: libreoffice-help-en-us: dependency problems - leaving unconfigured
E: libreoffice-impress: dependency problems - leaving unconfigured
E: libreoffice-math: dependency problems - leaving unconfigured
E: librpmio2: dependency problems - leaving unconfigured
E: librpm2: dependency problems - leaving unconfigured
E: librpmbuild2: dependency problems - leaving unconfigured
E: librpmsign0: dependency problems - leaving unconfigured
E: network-manager-gnome: dependency problems - leaving unconfigured
E: pidgin: dependency problems - leaving unconfigured
E: rpm2cpio: dependency problems - leaving unconfigured
E: rpm: dependency problems - leaving unconfigured
E: gnome-settings-daemon: dependency problems - leaving unconfigured
E: icedtea-6-jre-cacao: dependency problems - leaving unconfigured
E: icedtea-6-jre-jamvm: dependency problems - leaving unconfigured
E: libreoffice-style-human: dependency problems - leaving unconfigured
E: libreoffice-style-tango: dependency problems - leaving unconfigured
E: libreoffice-common: dependency problems - leaving unconfigured
E: openjdk-6-jre-lib: dependency problems - leaving unconfigured
E: libreoffice-java-common: dependency problems - leaving unconfigured

অভিজ্ঞ কেউ কি আমাকে সমস্যা সমাধানকল্পে কোনো পরামর্শ দিতে পারেন?
কোন প্যাকেজের কারণে সমস্যা সেটাই বুঝতেছি না।

শামীম'এর ওয়েবসাইট

লেখাটি CC by-nc-sa 3.0 এর অধীনে প্রকাশিত

Re: লিনাক্স মিন্ট ১৩ মায়াতে ব্রোকেন প্যাকেজ / ডিপেন্ডেন্সি সমস্যা - solved

sudo apt-get upgrade কমান্ড দিলে কি এরর দেয়?
অথবা sudo aptitude upgrade দিয়েও দেখতে পারেন, তবে yes করবেন না।

Feed থেকে ফোরাম সিগনেচার, imgsign.com
ব্লগ: shiplu.mokadd.im
মুখে তুলে কেউ খাইয়ে দেবে না। নিজের হাতেই সেটা করতে হবে।

শিপলু'এর ওয়েবসাইট

লেখাটি GPL v3 এর অধীনে প্রকাশিত

Re: লিনাক্স মিন্ট ১৩ মায়াতে ব্রোকেন প্যাকেজ / ডিপেন্ডেন্সি সমস্যা - solved

shamim@Shamim-HP-Pavilion-dv4-Notebook-PC ~ $ sudo apt-get upgrade
[sudo] password for shamim:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
libnss3 : Breaks: libnss3:i386 (!= 3.13.1.with.ckbi.1.88-1ubuntu6.1) but 3.14.1-0ckbi1.93ubuntu.0.12.04.1 is installed
libnss3:i386 : Breaks: libnss3 (!= 3.14.1-0ckbi1.93ubuntu.0.12.04.1) but 3.13.1.with.ckbi.1.88-1ubuntu6.1 is installed
libnss3-1d : Depends: libnss3 (= 3.14.1-0ckbi1.93ubuntu.0.12.04.1) but 3.13.1.with.ckbi.1.88-1ubuntu6.1 is installed
E: Unmet dependencies. Try using -f.



shamim@Shamim-HP-Pavilion-dv4-Notebook-PC ~ $ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  indicator-printers python-ubuntuone-client python-pygame unity-lens-video
  unity-scope-video-remote python-ubuntuone-storageprotocol libibus-1.0-0
  libunity-misc4 unity-lens-music lib32gcc1 appmenu-qt lib32asound2
  unity-lens-files indicator-appmenu unity-asset-pool lib32stdc++6 libsmpeg0
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libnss3 libnss3:i386 libnss3-1d
The following packages will be upgraded:
  libnss3 libnss3:i386 libnss3-1d
3 upgraded, 0 newly installed, 0 to remove and 352 not upgraded.
41 not fully installed or removed.
Need to get 0 B/2,467 kB of archives.
After this operation, 110 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
dpkg: error processing libnss3:i386 (--configure):
libnss3:i386 3.14.1-0ckbi1.93ubuntu.0.12.04.1 cannot be configured because libnss3:amd64 is in a different version (3.13.1.with.ckbi.1.88-1ubuntu6.1)
dpkg: error processing libnss3 (--configure):
libnss3:amd64 3.13.1.with.ckbi.1.88-1ubuntu6.1 cannot be configured because libnss3:i386 is in a different version (3.14.1-0ckbi1.93ubuntu.0.12.04.1)
dpkg: dependency problems prevent configuration of libnss3-1d:
libnss3-1d depends on libnss3 (= 3.14.1-0ckbi1.93ubuntu.0.12.04.1); however:
  Version of libnss3 on system is 3.13.1.with.ckbi.1.88-1ubuntu6.1.
dpkg: error processing libnss3-1d (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-core:
libreoffice-core depends on libnss3 (>= 3.12.0~1.9b1); however:
  Package libnss3 is not configured yet.
dpkg: error processing libreoffice-core (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent cNo apport report written because the error message indicates its a followup error from a previous failure.
                                                             No apport report written because the error message indicates its a followup error from a previous failure.
       No apport report written because MaxReports is reached already
                                                                     No apport report written because MaxReports is reached already
                                                   No apport report written because MaxReports is reached already
                                 No apport report written because MaxReports is reached already
               No apport report written because MaxReports is reached already
                                                                             No apport report written because MaxReports is reached already
                                                           onfiguration of libnm-util2:
libnm-util2 depends on libnss3 (>= 3.12.0~1.9b1); however:
  Package libnss3 is not configured yet.
dpkg: error processing libnm-util2 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libnm-glib4:
libnm-glib4 depends on libnm-util2 (>= 0.9.3.995+git201203081848.bba834f); however:
  Package libnm-util2 is not configured yet.
dpkg: error processing libnm-glib4 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of network-manager:
network-manager depends on libnm-glib4 (>= 0.9.4.0~git201203162258.69247a0); however:
  Package libnm-glib4 is not configured yet.
network-manager depends on libnm-util2 (>= 0.9.3.995+git201203081848.bba834f); however:
  Package libnm-util2 is not configured yet.
dpkg: error processing network-manager (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of openjdk-6-jrNo apport report written because MaxReports is reached already
                                             No apport report written because MaxReports is reached already
                           No apport report written because MaxReports is reached already
         No apport report written because MaxReports is reached already
                                                                       No apport report written because MaxReports is reached already
                                                     No apport report written because MaxReports is reached already
                                   No apport report written because MaxReports is reached already
                 No apport report written because MaxReports is reached already
                                                                               No apport report written because MaxReports is reached already
                                                             No apport report written because MaxReports is reached already
                                           No apport report written because MaxReports is reached already
                         No apport report written because MaxReports is reached already
       No apport report written because MaxReports is reached already
                                                                     e-headless:
openjdk-6-jre-headless depends on libnss3-1d (>= 3.12.9+ckbi-1.82-0ubuntu4); however:
  Package libnss3-1d is not configured yet.
dpkg: error processing openjdk-6-jre-headless (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gir1.2-networkmanager-1.0:
gir1.2-networkmanager-1.0 depends on libnm-glib4 (>= 0.9.4.0~git201203162258.69247a0); however:
  Package libnm-glib4 is not configured yet.
gir1.2-networkmanager-1.0 depends on libnm-util2 (>= 0.9.3.995+git201203081848.bba834f); however:
  Package libnm-util2 is not configured yet.
dpkg: error processing gir1.2-networkmanager-1.0 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libnm-glib-vpn1:
libnm-glib-vpn1 depends on libnm-util2 (>= 0.7.0); however:
  Package libnm-util2 is not configured yet.
dpkg: error processing libnm-glib-vpn1 (--configure):
dependency problems - leaving unconfigured
dpkg: dependencNo apport report written because MaxReports is reached already
                                                                             No apport report written because MaxReports is reached already
                                                           No apport report written because MaxReports is reached already
                                         No apport report written because MaxReports is reached already
                       No apport report written because MaxReports is reached already
     No apport report written because MaxReports is reached already
                                                                   No apport report written because MaxReports is reached already
                                                 No apport report written because MaxReports is reached already
                               No apport report written because MaxReports is reached already
             y problems prevent configuration of libnm-gtk0:
libnm-gtk0 depends on libnm-glib4 (>= 0.8.998); however:
  Package libnm-glib4 is not configured yet.
libnm-gtk0 depends on libnm-util2 (>= 0.9.2.0+git201202060518.95b0b72); however:
  Package libnm-util2 is not configured yet.
dpkg: error processing libnm-gtk0 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libpurple0:
libpurple0 depends on libnss3 (>= 3.12.0~1.9b1); however:
  Package libnss3 is not configured yet.
dpkg: error processing libpurple0 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-base-core:
libreoffice-base-core depends on libreoffice-core (= 1:3.5.7-0ubuntu4); however:
  Package libreoffice-core is not configured yet.
dpkg: error processing libreoffice-base-core (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of openjdk-6-jre:
openjdk-6-jre depends on openjdk-6-jre-headless (>= 6b27-1.12.3-0ubuntu1~12.04.1); however:
  Package openjdk-6-jre-headless is not configured yet.
dpkg: error processing openjdk-6-jre (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-base:
libreoffice-base depends on libreoffice-core (= 1:3.5.7-0ubuntu4); however:
  Package libreoffice-core is not configured yet.
libreoffice-base depends on libreoffice-base-core (= 1:3.5.7-0ubuntu4); however:
  Package libreoffice-base-core is not configured yet.
dpkg: error processing libreoffice-base (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-calc:
libreoffice-calc depends on libreoffice-core (= 1:3.5.7-0ubuntu4); however:
  Package libreoffice-core is not configured yet.
libreoffice-calc depends on libreoffice-base-core (= 1:3.5.7-0ubuntu4); however:
  Package libreoffice-base-core is not configured yet.
dpkg: error processing libreoffice-calc (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-draw:
libreoffice-draw depends on libreoffice-core (= 1:3.5.7-0ubuntu4); however:
  Package libreoffice-core is not configured yet.
dpkg: error processing libreoffice-draw (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-uno:
python-uno depends on libreoffice-core (= 1:3.5.7-0ubuntu4); however:
  Package libreoffice-core is not configured yet.
dpkg: error processing python-uno (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-emailmerge:
libreoffice-emailmerge depends on python-uno | python3-uno; however:
  Package python-uno is not configured yet.
  Package python3-uno is not installed.
libreoffice-emailmerge depends on libreoffice-core; however:
  Package libreoffice-core is not configured yet.
dpkg: error processing libreoffice-emailmerge (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-gtk:
libreoffice-gtk depends on libreoffice-core (= 1:3.5.7-0ubuntu4); however:
  Package libreoffice-core is not configured yet.
dpkg: error processing libreoffice-gtk (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-gnome:
libreoffice-gnome depends on libreoffice-core (= 1:3.5.7-0ubuntu4); however:
  Package libreoffice-core is not configured yet.
libreoffice-gnome depends on libreoffice-gtk; however:
  Package libreoffice-gtk is not configured yet.
dpkg: error processing libreoffice-gnome (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-writer:
libreoffice-writer depends on libreoffice-core (= 1:3.5.7-0ubuntu4); however:
  Package libreoffice-core is not configured yet.
libreoffice-writer depends on libreoffice-base-core (= 1:3.5.7-0ubuntu4); however:
  Package libreoffice-base-core is not configured yet.
dpkg: error processing libreoffice-writer (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-help-en-us:
libreoffice-help-en-us depends on libreoffice-writer | language-support-translations-en; however:
  Package libreoffice-writer is not configured yet.
  Package language-support-translations-en is not installed.
dpkg: error processing libreoffice-help-en-us (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-impress:
libreoffice-impress depends on libreoffice-core (= 1:3.5.7-0ubuntu4); however:
  Package libreoffice-core is not configured yet.
libreoffice-impress depends on libreoffice-draw (= 1:3.5.7-0ubuntu4); however:
  Package libreoffice-draw is not configured yet.
dpkg: error processing libreoffice-impress (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-math:
libreoffice-math depends on libreoffice-core (= 1:3.5.7-0ubuntu4); however:
  Package libreoffice-core is not configured yet.
dpkg: error processing libreoffice-math (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of librpmio2:
librpmio2 depends on libnss3 (>= 3.12.0~1.9b1); however:
  Package libnss3 is not configured yet.
dpkg: error processing librpmio2 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of librpm2:
librpm2 depends on librpmio2 (>= 4.9.0); however:
  Package librpmio2 is not configured yet.
dpkg: error processing librpm2 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of librpmbuild2:
librpmbuild2 depends on librpm2 (>= 4.9.0); however:
  Package librpm2 is not configured yet.
librpmbuild2 depends on librpmio2 (>= 4.9.0); however:
  Package librpmio2 is not configured yet.
dpkg: error processing librpmbuild2 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of librpmsign0:
librpmsign0 depends on librpm2 (>= 4.9.0); however:
  Package librpm2 is not configured yet.
librpmsign0 depends on librpmio2 (>= 4.9.0); however:
  Package librpmio2 is not configured yet.
dpkg: error processing librpmsign0 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of network-manager-gnome:
network-manager-gnome depends on libnm-glib-vpn1 (>= 0.7.999); however:
  Package libnm-glib-vpn1 is not configured yet.
network-manager-gnome depends on libnm-glib4 (>= 0.9.4.0~git201203162258.69247a0); however:
  Package libnm-glib4 is not configured yet.
network-manager-gnome depends on libnm-gtk0; however:
  Package libnm-gtk0 is not configured yet.
network-manager-gnome depends on libnm-util2 (>= 0.9.2.0+git201202060518.95b0b72); however:
  Package libnm-util2 is not configured yet.
network-manager-gnome depends on network-manager (>= 0.9.4); however:
  Package network-manager is not configured yet.
dpkg: error processing network-manager-gnome (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of pidgin:
pidgin depends on libpurple0 (>= 1:2.8.0-1); however:
  Package libpurple0 is not configured yet.
dpkg: error processing pidgin (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of rpm2cpio:
rpm2cpio depends on librpm2 (>= 4.9.0); however:
  Package librpm2 is not configured yet.
rpm2cpio depends on librpmio2 (>= 4.9.0); however:
  Package librpmio2 is not configured yet.
dpkg: error processing rpm2cpio (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of rpm:
rpm depends on librpm2 (>= 4.9.0); however:
  Package librpm2 is not configured yet.
rpm depends on librpmbuild2 (>= 4.9.0); however:
  Package librpmbuild2 is not configured yet.
rpm depends on librpmio2 (>= 4.9.0); however:
  Package librpmio2 is not configured yet.
rpm depends on librpmsign0 (>= 4.9.0); however:
  Package librpmsign0 is not configured yet.
rpm depends on rpm2cpio; however:
  Package rpm2cpio is not configured yet.
dpkg: error processing rpm (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-settings-daemon:
gnome-settings-daemon depends on libnss3 (>= 3.12.0~1.9b1); however:
  Package libnss3 is not configured yet.
dpkg: error processing gnome-settings-daemon (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of icedtea-6-jre-cacao:
icedtea-6-jre-cacao depends on openjdk-6-jre-headless (= 6b27-1.12.3-0ubuntu1~12.04.1); however:
  Package openjdk-6-jre-headless is not configured yet.
dpkg: error processing icedtea-6-jre-cacao (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of icedtea-6-jre-jamvm:
icedtea-6-jre-jamvm depends on openjdk-6-jre-headless (= 6b27-1.12.3-0ubuntu1~12.04.1); however:
  Package openjdk-6-jre-headless is not configured yet.
dpkg: error processing icedtea-6-jre-jamvm (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-style-human:
libreoffice-style-human depends on libreoffice-core; however:
  Package libreoffice-core is not configured yet.
dpkg: error processing libreoffice-style-human (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-style-tango:
libreoffice-style-tango depends on libreoffice-core; however:
  Package libreoffice-core is not configured yet.
dpkg: error processing libreoffice-style-tango (--configure):
dependency problemsNo apport report written because MaxReports is reached already
  No apport report written because MaxReports is reached already
                                                                No apport report written because MaxReports is reached already
                                              No apport report written because MaxReports is reached already
                            No apport report written because MaxReports is reached already
          No apport report written because MaxReports is reached already
                                                                        No apport report written because MaxReports is reached already
                                                      No apport report written because MaxReports is reached already
                                    No apport report written because MaxReports is reached already
                   - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-common:
libreoffice-common depends on libreoffice-style-default | libreoffice-style; however:
  Package libreoffice-style-default is not installed.
  Package libreoffice-style-human which provides libreoffice-style-default is not configured yet.
  Package libreoffice-style is not installed.
  Package libreoffice-style-tango which provides libreoffice-style is not configured yet.
  Package libreoffice-style-human which provides libreoffice-style is not configured yet.
dpkg: error processing libreoffice-common (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of openjdk-6-jre-lib:
openjdk-6-jre-lib depends on openjdk-6-jre-headless (>= 6b17); however:
  Package openjdk-6-jre-headless is not configured yet.
dpkg: error processing openjdk-6-jre-lib (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-java-common:
libreoffice-java-common depends on libreoffice-common; however:
  Package libreoffice-common is not configured yet.
dpkg: error processing libreoffice-java-common (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
libnss3:i386
libnss3
libnss3-1d
libreoffice-core
libnm-util2
libnm-glib4
network-manager
openjdk-6-jre-headless
gir1.2-networkmanager-1.0
libnm-glib-vpn1
libnm-gtk0
libpurple0
libreoffice-base-core
openjdk-6-jre
libreoffice-base
libreoffice-calc
libreoffice-draw
python-uno
libreoffice-emailmerge
libreoffice-gtk
libreoffice-gnome
libreoffice-writer
libreoffice-help-en-us
libreoffice-impress
libreoffice-math
librpmio2
librpm2
librpmbuild2
librpmsign0
network-manager-gnome
pidgin
rpm2cpio
rpm
gnome-settings-daemon
icedtea-6-jre-cacao
icedtea-6-jre-jamvm
libreoffice-style-human
libreoffice-style-tango
libreoffice-common
openjdk-6-jre-lib
libreoffice-java-common
E: Sub-process /usr/bin/dpkg returned an error code (1)


shamim@Shamim-HP-Pavilion-dv4-Notebook-PC ~ $ sudo aptitude upgrade
[sudo] password for shamim:
Resolving dependencies...               
Unable to resolve dependencies for the upgrade: no solution found.
Unable to safely resolve dependencies, try running with --full-resolver.

Re: লিনাক্স মিন্ট ১৩ মায়াতে ব্রোকেন প্যাকেজ / ডিপেন্ডেন্সি সমস্যা - solved

--full-resolver সহ রান করলে এ্যাত লম্বা আউটপুট আসে যে সেটা টারমিনালে পুরা ধরে না। নিচে যতটুকু পাওয়া গেল সেটুকু দিলাম।

isc-dhcp-common kdelibs-bin kdelibs5-data kdelibs5-plugins kdoctools
  language-selector-common language-selector-gnome libX11-dev
  libaccountsservice0 libapt-inst1.4 libapt-pkg4.12 libasound2
  libasound2:i386 libav-tools libavcodec53 libavdevice53 libavfilter2
  libavformat53 libavutil51 libbamf0 libbamf3-0 libbind9-80 libcups2
  libcups2:i386 libcupscgi1 libcupsdriver1 libcupsimage2 libcupsimage2:i386
  libcupsmime1 libcupsppdc1 libcurl3 libcurl3:i386 libcurl3-gnutls
  libcurl3-nss libdbus-1-3 libdbus-1-3:i386 libdbus-glib-1-2
  libdbus-glib-1-2:i386 libdbusmenu-glib4 libdbusmenu-gtk3-4
  libdbusmenu-gtk4 libdee-1.0-4 libdevmapper-event1.02.1 libdevmapper1.02.1
  libdmx1 libdns81 libdrm-dev libdrm-intel1 libdrm-intel1:i386
  libdrm-nouveau1a libdrm-nouveau1a:i386 libdrm-nouveau2 libdrm-radeon1
  libdrm-radeon1:i386 libdrm2 libdrm2:i386 libevince3-3 libfs6 libgck-1-0
  libgcr-3-1 libgcr-3-common libgl1-mesa-dev libgl1-mesa-dri
  libgl1-mesa-dri:i386 libgl1-mesa-glx libgl1-mesa-glx:i386 libglapi-mesa
  libglapi-mesa:i386 libglu1-mesa libglu1-mesa:i386 libglu1-mesa-dev
  libgnomekbd-common libgnomekbd7 libgnutls26 libgnutls26:i386 libgoa-1.0-0
  libgoa-1.0-common libgudev-1.0-0 libgudev-1.0-0:i386 libisc83 libisccc80
  libisccfg82 libjack-jackd2-0 libjack-jackd2-0:i386 libkcmutils4
  libkde3support4 libkdeclarative5 libkdecore5 libkdesu5 libkdeui5
  libkdewebkit5 libkdnssd4 libkemoticons4 libkfile4 libkhtml5 libkidletime4
  libkio5 libkjsapi4 libkjsembed4 libkmediaplayer4 libkms1 libknewstuff3-4
  libknotifyconfig4 libkntlm4 libkparts4 libkpty4 libkrosscore4
  libktexteditor4 liblvm2app2.2 liblwres80 libmuffin0 libmysqlclient18
  libmysqlclient18:i386 libnautilus-extension1a libnemo-extension1
  libneon27-gnutls libnepomuk4 libnepomukquery4a libnepomukutils4
  libnm-gtk-common libnm-gtk0 libnss3 libnss3:i386 libnss3-1d libopenjpeg2
  libpam-gnome-keyring libpam-winbind libperl5.14 libplasma3 libplymouth2
  libpoppler-glib8 libpoppler19 libpostproc52 libpq5
  libpulse-mainloop-glib0 libpulse-mainloop-glib0:i386 libpulse0
  libpulse0:i386 libpulsedsp libpulsedsp:i386 libservlet2.5-java
  libsmbclient libsolid4 libssl1.0.0 libssl1.0.0:i386 libswscale2
  libthreadweaver4 libtiff-tools libtiff4 libtiff4:i386 libudev0
  libudev0:i386 libusbmuxd1 libwbclient0 libx11-6 libx11-6:i386 libx11-data
  libx11-doc libx11-xcb1 libx11-xcb1:i386 libxatracker1 libxcb-composite0
  libxcb-dri2-0 libxcb-glx0 libxcb-glx0:i386 libxcb-randr0 libxcb-render0
  libxcb-render0:i386 libxcb-shape0 libxcb-shm0 libxcb-shm0:i386 libxcb-xv0
  libxcb1 libxcb1:i386 libxcb1-dev libxcursor1 libxcursor1:i386 libxext-dev
  libxext6 libxext6:i386 libxfixes3 libxfixes3:i386 libxi6 libxi6:i386
  libxinerama1 libxinerama1:i386 libxml2 libxml2:i386 libxml2-utils libxp6
  libxp6:i386 libxrandr2 libxrandr2:i386 libxrender1 libxrender1:i386
  libxres1 libxslt1.1 libxslt1.1:i386 libxt6 libxt6:i386 libxtst6
  libxtst6:i386 libxv1 libxv1:i386 libxvmc1 libxxf86dga1 libxxf86vm1
  libxxf86vm1:i386 linux-firmware linux-generic linux-headers-generic
  linux-image-generic linux-libc-dev linux-sound-base mdm mesa-common-dev
  mint-artwork-common mint-mdm-themes mintupload mountall mtools
  muffin-common multiarch-support mysql-common nautilus nautilus-data nemo
  nemo-data network-manager-gnome openjdk-6-jre openjdk-6-jre-headless
  openjdk-6-jre-lib openssh-client openssl perl perl-base perl-modules
  plymouth plymouth-label plymouth-theme-ubuntu-text poppler-utils
  pulseaudio pulseaudio-module-bluetooth pulseaudio-module-gconf
  pulseaudio-module-x11 pulseaudio-utils python-apt python-apt-common
  python-aptdaemon python-aptdaemon.gtk3widgets python-aptdaemon.pkcompat
  python-libxml2 python-paramiko python-problem-report rsyslog samba
  samba-common samba-common-bin simple-scan skype skype-bin:i386 smbclient
  ssh-askpass-gnome thunderbird thunderbird-gnome-support udev usbmuxd
  virtualbox-guest-dkms virtualbox-guest-utils virtualbox-guest-x11 winbind
  xorg xserver-common xserver-xorg xserver-xorg-core xserver-xorg-input-all
  xserver-xorg-input-evdev xserver-xorg-input-synaptics
  xserver-xorg-input-vmmouse xserver-xorg-input-wacom
  xserver-xorg-video-all xserver-xorg-video-intel
  xserver-xorg-video-nouveau xserver-xorg-video-qxl
  xserver-xorg-video-vmware youtube-dl
The following partially installed packages will be configured:
  gir1.2-networkmanager-1.0 gnome-settings-daemon libnm-glib-vpn1
  libnm-glib4 libnm-util2 libpurple0 libreoffice-base libreoffice-base-core
  libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw
  libreoffice-emailmerge libreoffice-gnome libreoffice-gtk
  libreoffice-help-en-us libreoffice-impress libreoffice-java-common
  libreoffice-math libreoffice-style-human libreoffice-style-tango
  libreoffice-writer librpm2 librpmbuild2 librpmio2 librpmsign0
  network-manager pidgin python-uno rpm rpm2cpio
The following packages are RECOMMENDED but will NOT be installed:
  firefox-globalmenu thunderbird-globalmenu xnest xserver-xephyr
  xul-ext-ubufox
353 packages upgraded, 6 newly installed, 0 to remove and 2 not upgraded.
Need to get 78.9 MB/352 MB of archives. After unpacking 225 MB will be used.
The following packages have unmet dependencies:
cinnamon-screensaver : Conflicts: gnome-screensaver but 3.4.1-0ubuntu1 is installed.
lib32asound2 : Depends: libasound2 (= 1.0.25-1ubuntu10.1) but 1.0.25-1ubuntu10.2 is to be installed.
open: 54; closed: 545; defer: 23; conflict: 32                                          .Internal error: the solver Install(dpkg:amd64 1.16.1.2ubuntu7 <libasound2:i386 1.0.25-1ubuntu10.2 -> {dpkg:amd64 1.16.1.2ubuntu7 dpkg:amd64 1.16.1.2ubuntu7.1 dpkg:i386 1.16.1.2ubuntu7 dpkg:i386 1.16.1.2ubuntu7.1}>) of a supposedly unresolved dependency is already installed in step 718
Internal error: the solver Install(dpkg:amd64 1.16.1.2ubuntu7 <libasound2:i386 1.0.25-1ubuntu10.2 -> {dpkg:amd64 1.16.1.2ubuntu7 dpkg:amd64 1.16.1.2ubuntu7.1 dpkg:i386 1.16.1.2ubuntu7 dpkg:i386 1.16.1.2ubuntu7.1}>) of a supposedly unresolved dependency is already installed in step 718
Internal error: the solver Install(dpkg:amd64 1.16.1.2ubuntu7 <wine-gecko1.4:i386 1.4.0-0ubuntu2 -> {dpkg:amd64 1.16.1.2ubuntu7 dpkg:amd64 1.16.1.2ubuntu7.1 dpkg:i386 1.16.1.2ubuntu7 dpkg:i386 1.16.1.2ubuntu7.1}>) of a supposedly unresolved dependency is already installed in step 718
Internal error: the solver Install(dpkg:amd64 1.16.1.2ubuntu7 <wine-gecko1.4:i386 1.4.0-0ubuntu2 -> {dpkg:amd64 1.16.1.2ubuntu7 dpkg:amd64 1.16.1.2ubuntu7.1 dpkg:i386 1.16.1.2ubuntu7 dpkg:i386 1.16.1.2ubuntu7.1}>) of a supposedly unresolved dependency is already installed in step 718
Internal error: the solver Install(dpkg:amd64 1.16.1.2ubuntu7 <libasound2:i386 1.0.25-1ubuntu10.2 -> {dpkg:amd64 1.16.1.2ubuntu7 dpkg:amd64 1.16.1.2ubuntu7.1 dpkg:i386 1.16.1.2ubuntu7 dpkg:i386 1.16.1.2ubuntu7.1}>) of a supposedly unresolved dependency is already installed in step 821
Internal error: the solver Install(dpkg:amd64 1.16.1.2ubuntu7 <libasound2:i386 1.0.25-1ubuntu10.2 -> {dpkg:amd64 1.16.1.2ubuntu7 dpkg:amd64 1.16.1.2ubuntu7.1 dpkg:i386 1.16.1.2ubuntu7 dpkg:i386 1.16.1.2ubuntu7.1}>) of a supposedly unresolved dependency is already installed in step 821
Internal error: the solver Install(dpkg:amd64 1.16.1.2ubuntu7 <wine-gecko1.4:i386 1.4.0-0ubuntu2 -> {dpkg:amd64 1.16.1.2ubuntu7 dpkg:amd64 1.16.1.2ubuntu7.1 dpkg:i386 1.16.1.2ubuntu7 dpkg:i386 1.16.1.2ubuntu7.1}>) of a supposedly unresolved dependency is already installed in step 821
Internal error: the solver Install(dpkg:amd64 1.16.1.2ubuntu7 <wine-gecko1.4:i386 1.4.0-0ubuntu2 -> {dpkg:amd64 1.16.1.2ubuntu7 dpkg:amd64 1.16.1.2ubuntu7.1 dpkg:i386 1.16.1.2ubuntu7 dpkg:i386 1.16.1.2ubuntu7.1}>) of a supposedly unresolved dependency is already installed in step 821
open: 109; closed: 715; defer: 46; conflict: 89                                              oInternal error: the solver Install(fontconfig-config:amd64 2.8.0-3ubuntu9 <libfontconfig1:i386 2.8.0-3ubuntu9 -> {fontconfig-config:amd64 2.8.0-3ubuntu9}>) of a supposedly unresolved dependency is already installed in step 994
Internal error: the solver Install(fontconfig-config:amd64 2.8.0-3ubuntu9 <libfontconfig1:i386 2.8.0-3ubuntu9 -> {fontconfig-config:amd64 2.8.0-3ubuntu9}>) of a supposedly unresolved dependency is already installed in step 994
open: 200; closed: 1446; defer: 122; conflict: 183                                           oInternal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: the solver Install(dpkg:amd64 1.16.1.2ubuntu7 <libasound2:i386 1.0.25-1ubuntu10.2 -> {dpkg:amd64 1.16.1.2ubuntu7 dpkg:amd64 1.16.1.2ubuntu7.1 dpkg:i386 1.16.1.2ubuntu7 dpkg:i386 1.16.1.2ubuntu7.1}>) of a supposedly unresolved dependency is already installed in step 1789
Internal error: the solver Install(dpkg:amd64 1.16.1.2ubuntu7 <libasound2:i386 1.0.25-1ubuntu10.2 -> {dpkg:amd64 1.16.1.2ubuntu7 dpkg:amd64 1.16.1.2ubuntu7.1 dpkg:i386 1.16.1.2ubuntu7 dpkg:i386 1.16.1.2ubuntu7.1}>) of a supposedly unresolved dependency is already installed in step 1789
Internal error: the solver Install(dpkg:amd64 1.16.1.2ubuntu7 <wine-gecko1.4:i386 1.4.0-0ubuntu2 -> {dpkg:amd64 1.16.1.2ubuntu7 dpkg:amd64 1.16.1.2ubuntu7.1 dpkg:i386 1.16.1.2ubuntu7 dpkg:i386 1.16.1.2ubuntu7.1}>) of a supposedly unresolved dependency is already installed in step 1789
Internal error: the solver Install(dpkg:amd64 1.16.1.2ubuntu7 <wine-gecko1.4:i386 1.4.0-0ubuntu2 -> {dpkg:amd64 1.16.1.2ubuntu7 dpkg:amd64 1.16.1.2ubuntu7.1 dpkg:i386 1.16.1.2ubuntu7 dpkg:i386 1.16.1.2ubuntu7.1}>) of a supposedly unresolved dependency is already installed in step 1789
open: 405; closed: 1953; defer: 292; conflict: 641                                           OInternal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: the solver Install(dpkg:amd64 1.16.1.2ubuntu7 <libasound2:i386 1.0.25-1ubuntu10.2 -> {dpkg:amd64 1.16.1.2ubuntu7 dpkg:amd64 1.16.1.2ubuntu7.1 dpkg:i386 1.16.1.2ubuntu7 dpkg:i386 1.16.1.2ubuntu7.1}>) of a supposedly unresolved dependency is already installed in step 2484
Internal error: the solver Install(dpkg:amd64 1.16.1.2ubuntu7 <libasound2:i386 1.0.25-1ubuntu10.2 -> {dpkg:amd64 1.16.1.2ubuntu7 dpkg:amd64 1.16.1.2ubuntu7.1 dpkg:i386 1.16.1.2ubuntu7 dpkg:i386 1.16.1.2ubuntu7.1}>) of a supposedly unresolved dependency is already installed in step 2484
Internal error: the solver Install(dpkg:amd64 1.16.1.2ubuntu7 <wine-gecko1.4:i386 1.4.0-0ubuntu2 -> {dpkg:amd64 1.16.1.2ubuntu7 dpkg:amd64 1.16.1.2ubuntu7.1 dpkg:i386 1.16.1.2ubuntu7 dpkg:i386 1.16.1.2ubuntu7.1}>) of a supposedly unresolved dependency is already installed in step 2484
Internal error: the solver Install(dpkg:amd64 1.16.1.2ubuntu7 <wine-gecko1.4:i386 1.4.0-0ubuntu2 -> {dpkg:amd64 1.16.1.2ubuntu7 dpkg:amd64 1.16.1.2ubuntu7.1 dpkg:i386 1.16.1.2ubuntu7 dpkg:i386 1.16.1.2ubuntu7.1}>) of a supposedly unresolved dependency is already installed in step 2484
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
open: 432; closed: 2105; defer: 300; conflict: 650                                           oInternal error: the solver Install(qdbus:i386 4:4.8.1-0ubuntu4.4 <libqt4-dbus:amd64 4:4.8.1-0ubuntu4.4 -S> {qdbus:amd64 4:4.8.1-0ubuntu4.4 qdbus:i386 4:4.8.1-0ubuntu4.4}>) of a supposedly unresolved dependency is already installed in step 2734
Internal error: the solver Install(qdbus:i386 4:4.8.1-0ubuntu4.4 <libqt4-dbus:amd64 4:4.8.1-0ubuntu4.4 -S> {qdbus:amd64 4:4.8.1-0ubuntu4.4 qdbus:i386 4:4.8.1-0ubuntu4.4}>) of a supposedly unresolved dependency is already installed in step 2734
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: the solver Install(dpkg:amd64 1.16.1.2ubuntu7 <libasound2:i386 1.0.25-1ubuntu10.2 -> {dpkg:amd64 1.16.1.2ubuntu7 dpkg:amd64 1.16.1.2ubuntu7.1 dpkg:i386 1.16.1.2ubuntu7 dpkg:i386 1.16.1.2ubuntu7.1}>) of a supposedly unresolved dependency is already installed in step 2900
Internal error: the solver Install(dpkg:amd64 1.16.1.2ubuntu7 <libasound2:i386 1.0.25-1ubuntu10.2 -> {dpkg:amd64 1.16.1.2ubuntu7 dpkg:amd64 1.16.1.2ubuntu7.1 dpkg:i386 1.16.1.2ubuntu7 dpkg:i386 1.16.1.2ubuntu7.1}>) of a supposedly unresolved dependency is already installed in step 2900
Internal error: the solver Install(dpkg:amd64 1.16.1.2ubuntu7 <wine-gecko1.4:i386 1.4.0-0ubuntu2 -> {dpkg:amd64 1.16.1.2ubuntu7 dpkg:amd64 1.16.1.2ubuntu7.1 dpkg:i386 1.16.1.2ubuntu7 dpkg:i386 1.16.1.2ubuntu7.1}>) of a supposedly unresolved dependency is already installed in step 2900
Internal error: the solver Install(dpkg:amd64 1.16.1.2ubuntu7 <wine-gecko1.4:i386 1.4.0-0ubuntu2 -> {dpkg:amd64 1.16.1.2ubuntu7 dpkg:amd64 1.16.1.2ubuntu7.1 dpkg:i386 1.16.1.2ubuntu7 dpkg:i386 1.16.1.2ubuntu7.1}>) of a supposedly unresolved dependency is already installed in step 2900
Internal error: the solver Install(qdbus:i386 4:4.8.1-0ubuntu4.4 <libqt4-dbus:amd64 4:4.8.1-0ubuntu4.4 -S> {qdbus:amd64 4:4.8.1-0ubuntu4.4 qdbus:i386 4:4.8.1-0ubuntu4.4}>) of a supposedly unresolved dependency is already installed in step 2980
Internal error: the solver Install(qdbus:i386 4:4.8.1-0ubuntu4.4 <libqt4-dbus:amd64 4:4.8.1-0ubuntu4.4 -S> {qdbus:amd64 4:4.8.1-0ubuntu4.4 qdbus:i386 4:4.8.1-0ubuntu4.4}>) of a supposedly unresolved dependency is already installed in step 2980
open: 462; closed: 2504; defer: 303; conflict: 653                                           .Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
The following actions will resolve these dependencies:

       Remove the following packages:                                           
1)       bluez-alsa:i386                                                         
2)       epanet2:i386                                                           
3)       glib-networking:i386                                                   
4)       google-earth-stable                                                     
5)       gstreamer0.10-plugins-base:i386                                         
6)       gstreamer0.10-plugins-good:i386                                         
7)       gstreamer0.10-x:i386                                                   
8)       gtk2-engines:i386                                                       
9)       gtk2-engines-murrine:i386                                               
10)      gtk2-engines-oxygen:i386                                               
11)      gtk2-engines-pixbuf:i386                                               
12)      gvfs:i386                                                               
13)      gvfs-libs:i386                                                         
14)      ia32-libs                                                               
15)      ia32-libs-multiarch:i386                                               
16)      ibus-gtk:i386                                                           
17)      lib32asound2                                                           
18)      libaa1:i386                                                             
19)      libacl1:i386                                                           
20)      libao4:i386                                                             
21)      libasn1-8-heimdal:i386                                                 
22)      libasound2:i386                                                         
23)      libasound2-plugins:i386                                                 
24)      libasyncns0:i386                                                       
25)      libatk1.0-0:i386                                                       
26)      libattr1:i386                                                           
27)      libaudio2:i386                                                         
28)      libaudiofile1:i386                                                     
29)      libavahi-client3:i386                                                   
30)      libavahi-common3:i386                                                   
31)      libavc1394-0:i386                                                       
32)      libbz2-1.0:i386                                                         
33)      libc6:i386                                                             
34)      libcaca0:i386                                                           
35)      libcairo-gobject2:i386                                                 
36)      libcairo2:i386                                                         
37)      libcanberra-gtk-module:i386                                             
38)      libcanberra-gtk0:i386                                                   
39)      libcanberra0:i386                                                       
40)      libcap2:i386                                                           
41)      libcapi20-3:i386                                                       
42)      libcdparanoia0:i386                                                     
43)      libcomerr2:i386                                                         
44)      libcroco3:i386                                                         
45)      libcups2:i386                                                           
46)      libcupsimage2:i386                                                     
47)      libcurl3:i386                                                           
48)      libdatrie1:i386                                                         
49)      libdb5.1:i386                                                           
50)      libdbus-1-3:i386                                                       
51)      libdbus-glib-1-2:i386                                                   
52)      libdbusmenu-qt2:i386                                                   
53)      libdrm-intel1:i386                                                     
54)      libdrm-nouveau1a:i386                                                   
55)      libdrm-radeon1:i386                                                     
56)      libdrm2:i386                                                           
57)      libdv4:i386                                                             
58)      libesd0:i386                                                           
59)      libexif12:i386                                                         
60)      libexpat1:i386                                                         
61)      libffi6:i386                                                           
62)      libflac8:i386                                                           
63)      libfontconfig1:i386                                                     
64)      libfreetype6:i386                                                       
65)      libgail-common:i386                                                     
66)      libgail18:i386                                                         
67)      libgcc1:i386                                                           
68)      libgconf-2-4:i386                                                       
69)      libgcrypt11:i386                                                       
70)      libgd2-xpm:i386                                                         
71)      libgdbm3:i386                                                           
72)      libgdk-pixbuf2.0-0:i386                                                 
73)      libgettextpo0:i386                                                     
74)      libgif4:i386                                                           
75)      libgl1-mesa-dri:i386                                                   
76)      libgl1-mesa-glx:i386                                                   
77)      libglapi-mesa:i386                                                     
78)      libglib2.0-0:i386                                                       
79)      libglu1-mesa:i386                                                       
80)      libgnome-keyring0:i386                                                 
81)      libgnutls26:i386                                                       
82)      libgomp1:i386                                                           
83)      libgpg-error0:i386                                                     
84)      libgphoto2-2:i386                                                       
85)      libgphoto2-port0:i386                                                   
86)      libgpm2:i386                                                           
87)      libgssapi-krb5-2:i386                                                   
88)      libgssapi3-heimdal:i386                                                 
89)      libgstreamer-plugins-base0.10-0:i386                                   
90)      libgstreamer0.10-0:i386                                                 
91)      libgtk2.0-0:i386                                                       
92)      libgudev-1.0-0:i386                                                     
93)      libhcrypto4-heimdal:i386                                               
94)      libheimbase1-heimdal:i386                                               
95)      libheimntlm0-heimdal:i386                                               
96)      libhx509-5-heimdal:i386                                                 
97)      libibus-1.0-0:i386                                                     
98)      libice6:i386                                                           
99)      libidn11:i386                                                           
100)     libiec61883-0:i386                                                     
101)     libieee1284-3:i386                                                     
102)     libjack-jackd2-0:i386                                                   
103)     libjasper1:i386                                                         
104)     libjpeg-turbo8:i386                                                     
105)     libjpeg8:i386                                                           
106)     libjson0:i386                                                           
107)     libk5crypto3:i386                                                       
108)     libkeyutils1:i386                                                       
109)     libkrb5-26-heimdal:i386                                                 
110)     libkrb5-3:i386                                                         
111)     libkrb5support0:i386                                                   
112)     liblcms1:i386                                                           
113)     libldap-2.4-2:i386                                                     
114)     libllvm3.0:i386                                                         
115)     libltdl7:i386                                                           
116)     libmad0:i386                                                           
117)     libmikmod2:i386                                                         
118)     libmng1:i386                                                           
119)     libmpg123-0:i386                                                       
120)     libmysqlclient18:i386                                                   
121)     libncurses5:i386                                                       
122)     libncursesw5:i386                                                       
123)     libnspr4:i386                                                           
124)     libnss3:i386                                                           
125)     libodbc1:i386                                                           
126)     libogg0:i386                                                           
127)     libopenal1:i386                                                         
128)     liborc-0.4-0:i386                                                       
129)     libp11-kit0:i386                                                       
130)     libpango1.0-0:i386                                                     
131)     libpciaccess0:i386                                                     
132)     libpcre3:i386                                                           
133)     libpixman-1-0:i386                                                     
134)     libpng12-0:i386                                                         
135)     libproxy1:i386                                                         
136)     libpulse-mainloop-glib0:i386                                           
137)     libpulse0:i386                                                         
138)     libpulsedsp:i386                                                       
139)     libqt4-dbus:i386                                                       
140)     libqt4-declarative:i386                                                 
141)     libqt4-designer:i386                                                   
142)     libqt4-network:i386                                                     
143)     libqt4-opengl:i386                                                     
144)     libqt4-qt3support:i386                                                 
145)     libqt4-script:i386                                                     
146)     libqt4-scripttools:i386                                                 
147)     libqt4-sql:i386                                                         
148)     libqt4-sql-mysql:i386                                                   
149)     libqt4-svg:i386                                                         
150)     libqt4-test:i386                                                       
151)     libqt4-xml:i386                                                         
152)     libqt4-xmlpatterns:i386                                                 
153)     libqtcore4:i386                                                         
154)     libqtgui4:i386                                                         
155)     libqtwebkit4:i386                                                       
156)     libraw1394-11:i386                                                     
157)     libroken18-heimdal:i386                                                 
158)     librsvg2-2:i386                                                         
159)     librsvg2-common:i386                                                   
160)     librtmp0:i386                                                           
161)     libsamplerate0:i386                                                     
162)     libsane:i386                                                           
163)     libsasl2-2:i386                                                         
164)     libsdl-image1.2:i386                                                   
165)     libsdl-mixer1.2:i386                                                   
166)     libsdl-net1.2:i386                                                     
167)     libsdl-ttf2.0-0:i386                                                   
168)     libsdl1.2debian:i386                                                   
169)     libselinux1:i386                                                       
170)     libshout3:i386                                                         
171)     libslang2:i386                                                         
172)     libsm6:i386                                                             
173)     libsndfile1:i386                                                       
174)     libsoup-gnome2.4-1:i386                                                 
175)     libsoup2.4-1:i386                                                       
176)     libspeex1:i386                                                         
177)     libspeexdsp1:i386                                                       
178)     libsqlite3-0:i386                                                       
179)     libssl0.9.8:i386                                                       
180)     libssl1.0.0:i386                                                       
181)     libstdc++5:i386                                                         
182)     libstdc++6:i386                                                         
183)     libtag1-vanilla:i386                                                   
184)     libtag1c2a:i386                                                         
185)     libtasn1-3:i386                                                         
186)     libtdb1:i386                                                           
187)     libthai0:i386                                                           
188)     libtheora0:i386                                                         
189)     libtiff4:i386                                                           
190)     libtinfo5:i386                                                         
191)     libudev0:i386                                                           
192)     libunistring0:i386                                                     
193)     libusb-0.1-4:i386                                                       
194)     libuuid1:i386                                                           
195)     libv4l-0:i386                                                           
196)     libv4lconvert0:i386                                                     
197)     libvisual-0.4-0:i386                                                   
198)     libvisual-0.4-plugins:i386                                             
199)     libvorbis0a:i386                                                       
200)     libvorbisenc2:i386                                                     
201)     libvorbisfile3:i386                                                     
202)     libwavpack1:i386                                                       
203)     libwind0-heimdal:i386                                                   
204)     libwrap0:i386                                                           
205)     libx11-6:i386                                                           
206)     libx11-xcb1:i386                                                       
207)     libxau6:i386                                                           
208)     libxaw7:i386                                                           
209)     libxcb-glx0:i386                                                       
210)     libxcb-render0:i386                                                     
211)     libxcb-shm0:i386                                                       
212)     libxcb1:i386                                                           
213)     libxcomposite1:i386                                                     
214)     libxcursor1:i386                                                       
215)     libxdamage1:i386                                                       
216)     libxdmcp6:i386                                                         
217)     libxext6:i386                                                           
218)     libxfixes3:i386                                                         
219)     libxft2:i386                                                           
220)     libxi6:i386                                                             
221)     libxinerama1:i386                                                       
222)     libxml2:i386                                                           
223)     libxmu6:i386                                                           
224)     libxp6:i386                                                             
225)     libxpm4:i386                                                           
226)     libxrandr2:i386                                                         
227)     libxrender1:i386                                                       
228)     libxslt1.1:i386                                                         
229)     libxss1:i386                                                           
230)     libxt6:i386                                                             
231)     libxtst6:i386                                                           
232)     libxv1:i386                                                             
233)     libxxf86vm1:i386                                                       
234)     odbcinst1debian2:i386                                                   
235)     skype                                                                   
236)     skype-bin:i386                                                         
237)     sni-qt:i386                                                             
238)     teighafileconverter:i386                                               
239)     wine                                                                   
240)     wine-gecko1.4:i386                                                     
241)     wine1.4                                                                 
242)     wine1.4-amd64                                                           
243)     wine1.4-common                                                         
244)     wine1.4-i386:i386                                                       
245)     xaw3dg:i386                                                             
246)     zlib1g:i386                                                             

       Keep the following packages at their current version:                     
247)     cinnamon-screensaver [Not Installed]                                   

       Leave the following dependencies unresolved:                             
248)     cinnamon recommends cinnamon-screensaver                               
249)     winetricks recommends wine1.4 | wine | cxoffice5 | cxgames5             
250)     wine-gecko1.4 recommends wine1.4-amd64                                 
251)     libcanberra-gtk0:i386 recommends libcanberra-gtk-module:i386           
252)     libncurses5:i386 recommends libgpm2:i386                               
253)     libncursesw5:i386 recommends libgpm2:i386                               
254)     libslang2:i386 recommends libpng12-0:i386                               
255)     libvisual-0.4-0:i386 recommends libvisual-0.4-plugins:i386             
256)     wine-gecko1.4:i386 recommends wine1.4-i386:i386                         
257)     gstreamer0.10-plugins-good:i386 recommends gstreamer0.10-x:i386         
258)     libgl1-mesa-glx:i386 recommends libgl1-mesa-dri:i386 (>= 7.2)           
259)     libgphoto2-2:i386 recommends udev:i386 (>= 0.175)                       
260)     libgphoto2-2:i386 recommends libgphoto2-l10n:i386 (>= 2.4.13-1ubuntu1.2)
261)     libqt4-dbus:i386 recommends qdbus:i386 (= 4:4.8.1-0ubuntu4.4)           
262)     wine1.4-i386:i386 recommends libfontconfig1:i386 | libfontconfig:i386   
263)     wine1.4-i386:i386 recommends libsane:i386                               
264)     skype-bin:i386 recommends sni-qt:i386                                   


Accept this solution? [Y/n/q/?]

শামীম'এর ওয়েবসাইট

লেখাটি CC by-nc-sa 3.0 এর অধীনে প্রকাশিত

Re: লিনাক্স মিন্ট ১৩ মায়াতে ব্রোকেন প্যাকেজ / ডিপেন্ডেন্সি সমস্যা - solved

শিপলুকে ধন্যবাদ। সমস্যাটা সমাধান করতে পেরেছি।

কীভাবে করলাম সেটা টুকে রাখি। কারও কাজে লাগলেও লাগতে পারে।
শেষ আউটপুটের শেষের লাইনগুলো দেখে মনে হল wine এ সমস্যা। তাই প্রথমে ওটার মধ্যে ইনস্টল করা একটা ক্যাড (প্রোজক্যাড, ফ্রী ভার্সন) আনইনস্টল করলাম। তারপর সিনাপ্টিক থেকে ওয়াইন আনইনস্টল করার চেষ্টা করতেই আবার বলে libnss3 এবং এর দুইটা চ্যালা সমস্যা করছে। এগুলোর যেই ভার্সন ইনস্টল করা আছে এর পরও লেটেস্ট ভার্সন আছে। কিন্তু আপগ্রেড/আপডেট করতে বললে এরর দেয়।

মূল হোতা libnss3 কে ফোর্স ভার্সন (packages --> force version ...) করে লেটেস্ট করতে বললাম। তা-ও ঝামেলা করে।

এরপর কী মনে করে জানি packages --> automatically installed অপশনটাও অন করে দিলাম। এরপর Apply দিতেই দেখি কাজ শুরু করে দিল। একে একে সবই আপডেট হয়েছে।
===

বেশ কিছুদিন যাবৎ উবুন্টু টুইক দিয়ে কিছু ক্লিন করতে চাচ্ছিলাম। সমস্ত কিছু আপডেট হওয়ার পরে সেটা করতে সক্ষম হলাম (উবুন্টু টুইক ইনস্টল হল অবশেষে)। LAMP সার্ভারও ইনস্টল করতে পারলাম। আহ্, এবার আশা করছি পিএইচপি স্ক্রিপ্টগুলো (লার্নিং: w3schools) টেস্ট করতে পারবো।  smile

শামীম'এর ওয়েবসাইট

লেখাটি CC by-nc-sa 3.0 এর অধীনে প্রকাশিত

Re: লিনাক্স মিন্ট ১৩ মায়াতে ব্রোকেন প্যাকেজ / ডিপেন্ডেন্সি সমস্যা - solved

অফটপিক:

শামীম লিখেছেন:

(লার্নিং: w3schools)

সতর্কতা: http://www.w3fools.com/  neutral

"No ship should go down without her captain."

হৃদয়১'এর ওয়েবসাইট

লেখাটি LGPL এর অধীনে প্রকাশিত

Re: লিনাক্স মিন্ট ১৩ মায়াতে ব্রোকেন প্যাকেজ / ডিপেন্ডেন্সি সমস্যা - solved

শামীম লিখেছেন:

শেষ আউটপুটের শেষের লাইনগুলো দেখে মনে হল wine এ সমস্যা।

এই কারণেই ঐ আউটপুটটা চেয়েছিলাম। এতে ধাপে ধাপে এররটা দেখা যায়। সাথে এরর কিভাবে প্রপাগেট করেছে তাও বোঝা যায়।

হৃদয়১ লিখেছেন:

অফটপিক:

শামীম লিখেছেন:

(লার্নিং: w3schools)

সতর্কতা: http://www.w3fools.com/  neutral

স্টার্টিং এর জন্য ঠিক আছে। তবে এডভান্স স্টেজে w3schools এর উপর ভরসা করা ঠিক না।
এই সাইটটা থেকে কোন কালেই কিছু শিখিনি। কিন্তু অনেক মানুষকে রেকমেন্ড করেছি। w3fools.com দেখার পর থেকে আর রেকমেন্ড করি না।

Feed থেকে ফোরাম সিগনেচার, imgsign.com
ব্লগ: shiplu.mokadd.im
মুখে তুলে কেউ খাইয়ে দেবে না। নিজের হাতেই সেটা করতে হবে।

Re: লিনাক্স মিন্ট ১৩ মায়াতে ব্রোকেন প্যাকেজ / ডিপেন্ডেন্সি সমস্যা - solved

হৃদয়১ লিখেছেন:

অফটপিক:

শামীম লিখেছেন:

(লার্নিং: w3schools)

সতর্কতা: http://www.w3fools.com/  neutral

ঠিকাছে! এরপর কাউকে রেফারেন্স দেয়ার ব্যাপারে সতর্ক হতে হবে।
আসলে বেশ কয়েকটা সোর্স থেকেই সিনটেক্সগুলো দেখছি। মূলত গুগল সার্চ ব্যবহার করি।  cool

শামীম'এর ওয়েবসাইট

লেখাটি CC by-nc-sa 3.0 এর অধীনে প্রকাশিত